Published:2010/06/22  Last Updated:2010/06/22

Explzh buffer overflow vulnerability


Explzh contains a buffer overflow vulnerability.

Products Affected

  • Explzh Ver.5.62 and earlier
Note that versions of Explzh that contain "Arcext.dll" version 2.16.1 and earlier are vulnerable.


Explzh, a file compression/decompression software supporting multiple compression file formats, contains a buffer overflow vulnerability when processing a LHA file header.


When processing a specially crafted LHA file, a remote attacker may be able to execute arbitrary code.


Update the Software
Update to the latest version according to the information provided by the developer.

Vendor Status

Vendor Status Last Update Vendor Notes
pon software Vulnerable 2010/06/22


JPCERT/CC Addendum

Vulnerability Analysis by JPCERT/CC

Analyzed on 2010.06.22

Measures Conditions Severity
Access Required Routed - can be attacked over the Internet using packets
  • High
Authentication None - anonymous or no authentication (IP addresses do not count)
  • High
User Interaction Required Simple - the user must be convinced to take a standard action that does not feel harmful to most users, such as click on a link or view a file
  • Medium
Exploit Complexity Low-Medium - some expertise and/or luck required (most buffer overflows, guessing correctly in small space, expertise in Windows function calls)
  • Medium-High

Description of each analysis measures


Kenju Takano reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.

Other Information

JPCERT Reports
CERT Advisory
CPNI Advisory
JVN iPedia JVNDB-2010-000026

Update History