Published:2008/12/19  Last Updated:2008/12/19

PHP vulnerable to cross-site scripting


PHP contains a cross-site scripting vulnerability.

Products Affected

  • PHP 5.2.7 and earlier
If PHP is configured with display_errors=off in php.ini, it is not affected.
Additionally, PHP 5.3.0alpha is not affected.


PHP is an open source scripting language that is especially suited for Web development. PHP contains a cross-site scripting vulnerability as it does not properly handle errors.


An arbitrary script may be executed on the user's web browser.


Update the Software
Apply the latest update provided by the developer.

According to the developer, PHP 4.X is no longer supported. Users of PHP 4.X are recommended to upgrade to PHP 5.2.X.

Vendor Status


JPCERT/CC Addendum

Vulnerability Analysis by JPCERT/CC

Analyzed on 2008.12.19

Measures Conditions Severity
Access Required Routed - can be attacked over the Internet using packets
  • High
Authentication None - anonymous or no authentication (IP addresses do not count)
  • High
User Interaction Required Simple - the user must be convinced to take a standard action that does not feel harmful to most users, such as click on a link or view a file
  • Medium
Exploit Complexity Low - little to no expertise and/or luck required to exploit (cross-site scripting)
  • High

Description of each analysis measures


Tomoki Sanaki of International Network Security, Inc. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.

Other Information

JPCERT Reports
CERT Advisory
CPNI Advisory
CVE CVE-2008-5814
JVN iPedia JVNDB-2008-000084

Update History