Published:2013/09/20  Last Updated:2013/09/20

D-Link DWL-2100AP vulnerable to denial-of-service (DoS)


DWL-2100AP provided by D-Link Japan contains a denial-of-service (DoS) vulnerability.

Products Affected

  • DWL-2100AP firmware versions prior to R252JP-RC572


DWL-2100AP provided by D-Link Japan contains a denial-of-service (DoS) vulnerability due to an issue in SSH implementation.


A user who can login with SSH may cause the product to reboot.


Update the Firmware
Update the firmware to version R252JP-RC572 or later according to the information provided by the developer.

Vendor Status

Vendor Link
D-Link Japan DWL-2100AP - firmware


JPCERT/CC Addendum

This JVN publication was delayed to 2013/09/20 after the developer fix was developed. From the fiscal year 2011, JPCERT/CC is using a new vendor coordination procedure. This new procedure came from the recommendation of the fiscal year 2010 "Study Group on Information System Vulnerability Handling" aimed at more timely JVN publications.

Vulnerability Analysis by JPCERT/CC

Analyzed on 2013.09.20

Measures Conditions Severity
Access Required can be attacked over the Internet using packets
  • High
Authentication login caused to be created by an administrator
  • Low-Mid
User Interaction Required the vulnerability can be exploited without an honest user taking any action
  • High
Exploit Complexity some expertise and/or luck required (most buffer overflows, guessing correctly in small space, expertise in Windows function calls)
  • Mid-High

Description of each analysis measures


Hisashi Kojima and Masahiro Nakada of Fujitsu Laboratories Ltd. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.

Other Information

JPCERT Reports
CERT Advisory
CPNI Advisory
CVE CVE-2013-4706
JVN iPedia JVNDB-2013-000089