Published:2011/01/11  Last Updated:2011/01/12

Aipo vulnerable to SQL injection


Aipo contains SQL injection vulnerability.

Products Affected

  • Aipo Version 5.1 and earlier
  • Aipo for ASP Version 5.1 and earlier


Aipo from Aimluck, Inc. is groupware including functions such as scheduler and intra-office blogging. Aipo contains a SQL injection vulnerability.


Contents that are managed by Aipo may be viewed by a user that can login to Aipo.


Update the Software
Update to the latest version according to the information provided by the developer.

This issue has been resolved in Aipo Version

Vendor Status

Vendor Status Last Update Vendor Notes
Aimluck,Inc. vulnerable 2011/01/12


JPCERT/CC Addendum

Vulnerability Analysis by JPCERT/CC

Analyzed on 2011.01.11

Measures Conditions Severity
Access Required can be attacked over the Internet using packets
  • High
Authentication login caused to be created by an administrator
  • Low-Mid
User Interaction Required the vulnerability can be exploited without an honest user taking any action
  • High
Exploit Complexity the user must be convinced to take a difficult or suspicious action. If the honest user must have elevated privileges, they are likely to be more suspiciouse
  • High

Description of each analysis measures


Yuki Urabe reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.

Other Information

JPCERT Reports
CERT Advisory
CPNI Advisory
CVE CVE-2010-3924
JVN iPedia JVNDB-2011-000003

Update History

Published in English.