Published:2013/12/24  Last Updated:2013/12/24

IrfanView vulnerable to buffer overflow


IrfanView contains a buffer overflow vulnerability.

Products Affected

  • IrfanView 4.36 and earlier


IrfanView is an application for viewing images of many different file formats.
IrfanView contains a buffer overflow vulnerability, when using the Thumbnails window with Thumbnail tooltips enabled.


When processing a specially crafted file contained in a folder named using multi-byte characters, the program will crash and arbitrary code may be executed.


Update the Software
Update to the latest version according to the information provided by the developer.

Vendor Status


JPCERT/CC Addendum

Vulnerability Analysis by JPCERT/CC

Analyzed on 2013.12.24

Measures Conditions Severity
Access Required can be attacked over the Internet using packets
  • High
Authentication anonymous or no authentication (IP addresses do not count)
  • High
User Interaction Required the user must be convinced to take a standard action that does not feel harmful to most users, such as click on a link or view a file
  • Mid
Exploit Complexity some expertise and/or luck required (most buffer overflows, guessing correctly in small space, expertise in Windows function calls)
  • Mid-High

Description of each analysis measures


Asuka Nakajima of NTT Secure Platform Laboratories reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.

Other Information

JPCERT Reports
CERT Advisory
CPNI Advisory
CVE CVE-2013-6932
JVN iPedia JVNDB-2013-000120