Published:2011/07/28  Last Updated:2011/08/01

Mozilla Firefox vulnerable to cross-site scripting


Mozilla Firefox contains a cross-site scripting vulnerability.

Products Affected

  • Mozilla Firefox prior to 3.6


Mozilla Firefox contains a vulnerability in the rendering of specific numeric character references, which may result in cross-site scripting.


An arbitrary script may be executed on the user's web browser.


Update the Software
Update to the latest version according to the information provided by the developer.

Vendor Status

Vendor Status Last Update Vendor Notes
Mozilla Japan vulnerable 2011/07/28


JPCERT/CC Addendum

This JVN publication was delayed to 2011/07/28 after developer fixes were developed. From the fiscal year 2011, JPCERT/CC is using a new vendor coordination procedure. This new procedure came from the recommendation of the fiscal year 2010 "Study Group on Information System Vulnerability Handling" aimed at more timely JVN publications.

Vulnerability Analysis by JPCERT/CC

Analyzed on 2011.07.28

Measures Conditions Severity
Access Required can be attacked over the Internet using packets
  • High
Authentication anonymous or no authentication (IP addresses do not count)
  • High
User Interaction Required the user must be convinced to take a standard action that does not feel harmful to most users, such as click on a link or view a file
  • Mid
Exploit Complexity some expertise and/or luck required (most buffer overflows, guessing correctly in small space, expertise in Windows function calls)
  • Mid-High

Description of each analysis measures


Takeshi Terada of Mitsui Bussan Secure Directions, Inc. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.

Other Information

JPCERT Reports
CERT Advisory
CPNI Advisory
CVE CVE-2008-4066
JVN iPedia JVNDB-2011-000058

Update History

CVE was added under the section "Other Information."