公開日:2020/08/25 最終更新日:2020/08/25

JVN#50890770
Apache Struts 2 にサービス運用妨害 (DoS) の脆弱性

概要

Apache Struts 2 にはサービス運用妨害 (DoS) の脆弱性が存在します。

影響を受けるシステム

  • Struts 2.0.0 から 2.5.20 までのバージョン

詳細情報

Apache Struts 2 にはサービス運用妨害 (DoS) (CWE-400) の脆弱性が存在します。

想定される影響

第三者によって、サービス運用妨害 (DoS) 攻撃を受ける可能性があります。

対策方法

アップデートする
開発者が提供する情報をもとに、最新版にアップデートしてください。

ワークアラウンドを実施する
struts-default.xml の定数 struts.excludedPackageNames の Value 属性に java.io. と java.nio. を追加してください

ただし、The Apache Software Foundation はワークアラウンドの実施よりもアップデートの実施を推奨しています。

ベンダ情報

ベンダ ステータス ステータス
最終更新日
ベンダの告知ページ
BizMobile株式会社 該当製品無し 2020/08/25
アズビル株式会社 脆弱性情報提供済み 2020/08/25
ジェイティ エンジニアリング株式会社 該当製品無し 2020/08/25
ソニー株式会社 脆弱性情報提供済み 2020/08/25
住友電気工業株式会社 該当製品無し 2020/08/25
富士通株式会社 該当製品無し 2020/08/25
日本電気株式会社 該当製品無し(調査中) 2020/08/25
東芝テック株式会社 該当製品無し 2020/08/25
株式会社JVCケンウッド 脆弱性情報提供済み 2020/08/25
株式会社エヌ・ティ・ティ・データ 該当製品無し 2020/08/25
株式会社ジャストシステム 脆弱性情報提供済み 2020/08/25
株式会社東芝 該当製品あり(調査中) 2020/08/25
ベンダ リンク
The Apache Software Foundation S2-060 - Apache Struts 2 Wiki - Apache Software Foundation

参考情報

JPCERT/CCからの補足情報

JPCERT/CCによる脆弱性分析結果

CVSS v3 CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
基本値: 5.9
攻撃元区分(AV) 物理 (P) ローカル (L) 隣接 (A) ネットワーク (N)
攻撃条件の複雑さ(AC) 高 (H) 低 (L)
必要な特権レベル(PR) 高 (H) 低 (L) 不要 (N)
ユーザ関与レベル(UI) 要 (R) 不要 (N)
スコープ(S) 変更なし (U) 変更あり (C)
機密性への影響(C) なし (N) 低 (L) 高 (H)
完全性への影響(I) なし (N) 低 (L) 高 (H)
可用性への影響(A) なし (N) 低 (L) 高 (H)
CVSS v2 AV:N/AC:M/Au:N/C:N/I:N/A:P
基本値: 4.3
攻撃元区分(AV) ローカル (L) 隣接 (A) ネットワーク (N)
攻撃条件の複雑さ(AC) 高 (H) 中 (M) 低 (L)
攻撃前の認証要否(Au) 複数 (M) 単一 (S) 不要 (N)
機密性への影響(C) なし (N) 部分的 (P) 全面的 (C)
完全性への影響(I) なし (N) 部分的 (P) 全面的 (C)
可用性への影響(A) なし (N) 部分的 (P) 全面的 (C)

謝辞

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 三井物産セキュアディレクション 寺田 健 氏

関連文書

JPCERT 緊急報告
JPCERT REPORT
CERT Advisory
CPNI Advisory
TRnotes
CVE CVE-2019-0233
JVN iPedia JVNDB-2020-000055