公開日:2017/01/27 最終更新日:2017/10/02

JVNVU#92830136
OpenSSL に複数の脆弱性

概要

OpenSSL には、複数の脆弱性が存在します。

影響を受けるシステム

脆弱性とその影響を受ける OpenSSL のバージョンは以下の通りです:

  CVE-2017-3730 CVE-2017-3731 CVE-2017-3732 CVE-2016-7055
OpenSSL 1.1.0d より前のバージョン x x x  
OpenSSL 1.0.2k より前のバージョン   x x x

詳細情報

OpenSSL は、次に挙げる脆弱性を修正したアップデートをリリースしました。

  • 細工された(Truncated) パケットが、範囲外 (out-of-bounds) の読み込みを通じてクラッシュする可能性 - CVE-2017-3731 (重要度:中)
  • 不正な (EC)DHE パラメータによりクライアントがクラッシュする可能性 - CVE-2017-3730 (重要度:中)
  • BN_mod_exp 関数処理の x86_64 環境での誤り - CVE-2017-3732 (重要度:中)
  • モンゴメリ乗算処理の誤り - CVE-2016-7055 (重要度:低)

想定される影響

想定される影響は各脆弱性により異なりますが、アプリケーションがクラッシュするサービス運用妨害 (DoS) 攻撃を受けるなどの可能性があります。

対策方法

アップデートする
本脆弱性を修正した OpenSSL 1.1.0d および 1.0.2k がリリースされています。
開発者が提供する情報をもとに、最新版へアップデートして下さい。

ベンダ情報

ベンダ ステータス ステータス
最終更新日
ベンダの告知ページ
BizMobile株式会社 該当製品あり(調査中) 2017/01/27
ジェイティ エンジニアリング株式会社 該当製品無し 2017/04/03
日本電気株式会社 該当製品あり 2017/09/29

参考情報

JPCERT/CCからの補足情報

JPCERT/CCによる脆弱性分析結果

謝辞

関連文書

JPCERT 緊急報告
JPCERT REPORT
CERT Advisory
CPNI Advisory
TRnotes
CVE CVE-2017-3731
CVE-2017-3730
CVE-2017-3732
CVE-2016-7055
JVN iPedia

更新履歴

2017/01/27
BizMobile株式会社のベンダステータスが更新されました
2017/04/03
ジェイティ エンジニアリング株式会社のベンダステータスが更新されました
2017/07/25
日本電気株式会社のベンダステータスが更新されました
2017/10/02
日本電気株式会社のベンダステータスが更新されました