公開日:2021/01/22 最終更新日:2021/02/17

JVNVU#94008268
M&M Software 製 fdtCONTAINER に信頼できないデータのデシリアライズの脆弱性

概要

M&M Software 社 (WAGO Kontakttechnik 社子会社) が提供する fdtCONTAINER には、信頼できないデータのデシリアライズの脆弱性が存在します。

影響を受けるシステム

  • fdtCONTAINER component
    • バージョン 3.5.0 から 3.5.20304.x より前のバージョン
    • バージョン 3.6.0 から 3.6.20304.x より前のバージョン
    • バージョン 3.5 より前のバージョン
  • fdtCONTAINER application
    • バージョン 4.5.0 から 4.5.20304.x より前のバージョン
    • バージョン 4.6.0 から 4.6.20304.x より前のバージョン
    • バージョン 4.5 より前のバージョン
  • FDT 1.2.x をベースにした dtmINSPECTOR バージョン 3
また、下記の製品が影響を受けるコンポーネントを利用しているとのことです。
  • Emerson Rosemount Transmitter Interface Software (RTIS) SKUs: 04088-9000-0001、04088-9000-0002、7000003-312
  • PEPPERL+FUCHS PACTware バージョン 5.0 から 5.0.5.31
  • Weidmüller WI Manager up to and including バージョン 2.5.1 およびそれ以前
  • 三菱電機株式会社 MELSOFT FieldDeviceConfigurator すべてのバージョン

詳細情報

M&M Software 社 (WAGO Kontakttechnik 社子会社) が提供し、RTIS および PACTware を含む他の製品にも使われている fdtCONTAINER コンポーネントには、信頼できないデータのデシリアライズ (CWE-502) の脆弱性が存在します。

想定される影響

第三者によって、細工されたプロジェクトファイルをユーザが読み込むことで、不正なコードを秘密裏に実行される可能性があります。

対策方法

アップデートする
開発者が提供する情報をもとに、利用方法に応じて下記のオプションから修正済みバージョンにアップデートしてください。
詳細は開発者へお問い合わせください。

オプション1:確認されている攻撃手法に対処し、既存のプロジェクトファイルと互換性があるが、非推奨のデシリアライゼーション技術を利用している
fdtCONTAINER component、fdtCONTAINER application

  • fdtCONTAINER component バージョン 3.5.20304.x から 3.7 より前のバージョン
  • fdtCONTAINER application バージョン 4.6.20304.x から 4.7 より前のバージョン
オプション2:既存のプロジェクトファイルと互換性がないが、推奨される安全なデシリアライゼーション技術を利用している

fdtCONTAINER component、fdtCONTAINER application
  • fdtCONTAINER component バージョン 3.7 およびそれ以降のバージョン
  • fdtCONTAINER application バージョン 4.7 およびそれ以降のバージョン
dtmINSPECTOR
  • 修正済みバージョンを2021年第一四半期に提供予定とのことです。
RTIS PEPPERL+FUCHS PACTware Weidmüller WI Manager ワークアラウンドを実施する
開発者が提供する情報をもとに、回避策を適用することで本脆弱性の影響を軽減できます。

三菱電機株式会社 MELSOFT FieldDeviceConfigurator

ベンダ情報

ベンダ ステータス ステータス
最終更新日
ベンダの告知ページ
三菱電機株式会社 該当製品あり 2021/02/16 三菱電機株式会社 の告知ページ
ベンダ リンク
Emerson Electric Co. Emerson Cybersecurity Notification Alert EMR.RMT20004-3 (PDF)

参考情報

  1. VDE-2020-048 (2021-01-14 15:58 UTC+0100)
    WAGO/M&M Software: Deserialization of untrusted data in fdtContainer
  2. VDE-2021-001 (2021-01-15 13:41 UTC+0100)
    PEPPERL+FUCHS: Vulnerability allowing code-excution in PACTware <= 5.0.5.31
  3. VDE-2021-002 (2021-01-20 14:32 UTC+0100)
    WEIDMUELLER: WI Manager affected by fdtContainer vulnerability
  4. ICS Advisory (ICSA-21-021-05)
    WAGO M&M Software fdtCONTAINER

JPCERT/CCからの補足情報

JPCERT/CCによる脆弱性分析結果

CVSS v3 CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
基本値: 7.3
攻撃元区分(AV) 物理 (P) ローカル (L) 隣接 (A) ネットワーク (N)
攻撃条件の複雑さ(AC) 高 (H) 低 (L)
必要な特権レベル(PR) 高 (H) 低 (L) 不要 (N)
ユーザ関与レベル(UI) 要 (R) 不要 (N)
スコープ(S) 変更なし (U) 変更あり (C)
機密性への影響(C) なし (N) 低 (L) 高 (H)
完全性への影響(I) なし (N) 低 (L) 高 (H)
可用性への影響(A) なし (N) 低 (L) 高 (H)

謝辞

関連文書

JPCERT 緊急報告
JPCERT REPORT
CERT Advisory
CPNI Advisory
TRnotes
CVE CVE-2020-12525
JVN iPedia

更新履歴

2021/02/05
[影響を受けるシステム], [詳細情報], [対策方法], [参考情報] を更新しました。
2021/02/05
[タイトル], [概要], [詳細情報], [対策方法], [ベンダ情報リンク], [参考情報] を修正しました。
2021/02/16
三菱電機株式会社のベンダステータスが更新されました
2021/02/17
[影響を受けるシステム], [対策方法] を修正しました