公開日:2016/12/28 最終更新日:2017/01/06

JVNVU#99931177
PHPMailer に OS コマンドインジェクションの脆弱性
緊急

概要

PHPMailer には、OS コマンドインジェクションの脆弱性があります。

影響を受けるシステム

次のライブラリを使用しているウェブアプリケーションが本脆弱性の影響を受けます。

  • PHPMailer 5.2.20 より前のバージョン

詳細情報

PHPMailer は、PHP で作成されたウェブアプリケーションにメールの送信機能を追加するためのライブラリです。PHPMailer には、OS コマンドインジェクション (CWE-78) の脆弱性が存在します。

なお、本脆弱性を使用した攻撃コードが公開されています。

想定される影響

想定される影響はウェブアプリケーションの実装によりますが、ウェブアプリケーションの実行権限で任意の OS コマンドが実行される可能性があります。

対策方法

アップデートする
開発者が提供する情報をもとに、PHPMailer を最新版へアップデートしてください。

ベンダ情報

ベンダ ステータス ステータス
最終更新日
ベンダの告知ページ
アライドテレシス株式会社 該当製品無し 2017/01/06

参考情報

  1. LEGAL HACKERS
    PHPMailer < 5.2.18 Remote Code Execution
  2. LEGAL HACKERS
    PHPMailer < 5.2.20 Remote Code Execution (0day Patch Bypass/exploit)
  3. Paul Buonopane of NamePros Raw
    Analysis of PHPMailer's RCE vulnerabilities CVE-2016-10033 and CVE-2016-10045

JPCERT/CCからの補足情報

JPCERT/CCによる脆弱性分析結果

CVSS v3 CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
基本値: 5.4
攻撃元区分(AV) 物理 (P) ローカル (L) 隣接 (A) ネットワーク (N)
攻撃条件の複雑さ(AC) 高 (H) 低 (L)
必要な特権レベル(PR) 高 (H) 低 (L) 不要 (N)
ユーザ関与レベル(UI) 要 (R) 不要 (N)
スコープ(S) 変更なし (U) 変更あり (C)
機密性への影響(C) なし (N) 低 (L) 高 (H)
完全性への影響(I) なし (N) 低 (L) 高 (H)
可用性への影響(A) なし (N) 低 (L) 高 (H)
CVSS v2 AV:N/AC:L/Au:S/C:P/I:P/A:N
基本値: 5.5
攻撃元区分(AV) ローカル (L) 隣接 (A) ネットワーク (N)
攻撃条件の複雑さ(AC) 高 (H) 中 (M) 低 (L)
攻撃前の認証要否(Au) 複数 (M) 単一 (S) 不要 (N)
機密性への影響(C) なし (N) 部分的 (P) 全面的 (C)
完全性への影響(I) なし (N) 部分的 (P) 全面的 (C)
可用性への影響(A) なし (N) 部分的 (P) 全面的 (C)

分析結果のコメント

ウェブアプリケーションにログインした攻撃者が、細工した情報を入力する攻撃を想定しています。

謝辞

関連文書

JPCERT 緊急報告
JPCERT REPORT
CERT Advisory
CPNI Advisory
TRnotes
CVE CVE-2016-10033
CVE-2016-10045
JVN iPedia

更新履歴

2016/12/30
PHPMailer 5.2.20 の公開にあわせて更新しました。
2017/01/06
アライドテレシス株式会社のベンダステータスが更新されました