Published:2012/02/22  Last Updated:2012/05/31

Multiple COOKPAD applications for Android vulnerable in WebView class


Multiple COOKPAD applications for Android contain a vulnerability in WebView class.

Products Affected

  • Cookpad (Android) 1.5.16 and earlier
  • Cookpad Noseru (Android) 1.1.1 and earlier


Cookpad and Cookpad Noseru provided by COOKPAD Inc. are Android applications to search or post recipes. Cookpad and Cookpad Noseru contain a vulnerability in WebView class.


If an user of the affected product uses other malicious Android application, the information contained in the affected product may be disclosed.


Update the Software
Apply the latest update for each application according to the information provided by the developer.


JPCERT/CC Addendum

Vulnerability Analysis by JPCERT/CC

Analyzed on 2012.02.22

Measures Conditions Severity
Access Required can be attacked over the Internet using packets
  • High
Authentication anonymous or no authentication (IP addresses do not count)
  • High
User Interaction Required the user must be convinced to take a difficult or suspicious action. If the honest user must have elevated privileges, they are likely to be more suspicious
  • Low
Exploit Complexity some expertise and/or luck required (most buffer overflows, guessing correctly in small space, expertise in Windows function calls)
  • Mid-High

Description of each analysis measures


This analysis assumes that the user is tricked into installing a malicious application.


Gaku Mochizuki of Mitsui Bussan Secure Directions, Inc. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.

Other Information

JPCERT Reports
CERT Advisory
CPNI Advisory
CVE CVE-2012-0316
JVN iPedia JVNDB-2012-000014

Update History

Information under the section "Vendor Status" was added.
Comment under the section "Vulnerability Analysis by JPCERT/CC" was modified.