Published:2013/11/07  Last Updated:2013/11/07

Page Scroller vulnerable to cross-site scripting


The ZIP archive for Page Scroller contains an issue where it includes a version of jQuery that is vulnerable to cross-site scripting.

Products Affected

  • Page Scroller ver.3.0.8 and earlier


Page Scroller from coliss is a script that uses jQuery.  In addition to Page Scroller being avaliable just as a script, it is also available as a ZIP archive that includes jQuery and demo files.

The jQuery included in the ZIP archive contains a known cross-site scripting vulnerability (CVE-2011-4969).


An arbitrary script may be executed on the user's web browser.


Apply an update
Update to the latest version according to the information provided by the developer.

According to the developer, Page Scroller version 3.0.9 is not vulnerable to the jQuery issue even if the older version of jQuery is being referenced.

Vendor Status

Vendor Link
coliss Page Scroller ver.3


JPCERT/CC Addendum

Vulnerability Analysis by JPCERT/CC

Analyzed on 2013.11.07

Measures Conditions Severity
Access Required can be attacked over the Internet using packets
  • High
Authentication anonymous or no authentication (IP addresses do not count)
  • High
User Interaction Required the user must be convinced to take a standard action that does not feel harmful to most users, such as click on a link or view a file
  • Mid
Exploit Complexity the user must be convinced to take a difficult or suspicious action. If the honest user must have elevated privileges, they are likely to be more suspiciouse
  • High

Description of each analysis measures


Other Information

JPCERT Reports
CERT Advisory
CPNI Advisory
CVE CVE-2013-5989
JVN iPedia JVNDB-2013-000102